Tubeless issues….

Forums Mountain Bike Forum Tubeless issues….

--
SHARES
  

Tagged: , , ,

Viewing 3 reply threads
  • Author
    Posts
    • #126596

      OK.. To start, I am having issues getting my new tires to set on my tubeless rims. I have a set of WTB Frequency i23 tubeless rims.

      I had been riding a set of Kenda Small Block 8 2.1 tires on the rims tubeless. I was able to inflate these with a hand pump. I decided to upgrade my tires to a more aggressive tread.

      So I bought a set of Continental Trail Kings in a 2.2. Could not get these tires to set at all. Couldn’t get the bead of the tire on the rim. I used an air compressor and ratchet strap to try and make a better seal, but this didn’t work either. After messing with it for a couple of evenings, I put tubes in the them as to get a ride in, but that is a temp fix. I was hoping to make them tubeless.

      Thoughts?

      Thanks!

    • #126597

      Leave the tubes in for a bit so the tires take shape, week or so should do the trick.
      I’ve had to do this a few times with new tires that would not set-up no matter what I did..

    • #126598

      Appreciate the advise. I will try that.

      Thanks!

    • #126599
      "slipfinger" wrote

      Leave the tubes in for a bit so the tires take shape, week or so should do the trick.
      I’ve had to do this a few times with new tires that would not set-up no matter what I did..

      +1 for this, I have had to do it with certain tires as well.

Viewing 3 reply threads
RELATED TOPICS

You must be logged in to reply to this topic.