Trouble with avid elixer brake calipers.

Forums Mountain Bike Forum Trouble with avid elixer brake calipers.

Viewing 1 reply thread
  • Author
    Posts
    • #217677

      Hello! im new to this whole scene. I have a little background in other mechanics. I just bought a 2011 stumpjumper for my first mountain bike. i decided to check the brake pads to see if it needed replacing since it was squeaking a lot. When i put the pads back on the front brakes banjo bolt wont seal with the hose. Anyone have any idea whats going on? Please help! Thanks!

    • #217754

      It sounds like something independent of the pads is wrong. Replacing the pads should never effect the banjo bolt. Also, the banjo doesn’t just come loose over time like other bolts can. It sounds like the brakes were not properly maintained or assembled at some point, my guess would be the latter.

      I don’t know how much you’ve researched those particular brakes either, but the noise they were making could be irreparable. Avid elixirs from a few years back were some of the worst manufactured brakes of all time. I have Sram guides and Shimano zees myself, and I’ve worked on most every brand under the sun, so I’m not trying to bash avid. The elixirs are great when they work.

      I will say the most efficient repair for avid elixirs in terms of time, money, blood, sweat, and tears, is almost always a new set of brakes. If you can spend less than a week fixing them and less than $100 dollars you’re not out too much time and money and you probably learned something. I’ve never seen a set of elixirs successfully repaired however. You either get a good set and bleed them perfectly, or you’re screwed.

      As for fixing the problem you have, just a new banjo fitting for the caliper end, or an entire new hose for the front brake. You should be able to just trim the caliper end of the hose by an inch or so and fit a new banjo bolt, with seals, for less than $20 including gas money to get to the bike shop.

      I can’t stress enough though, don’t expect the noise to go away or for this to be the last problem. Take the time to Google “Avid elixir” and you’ll see what I mean.

      Good luck, and have a good one

Viewing 1 reply thread

You must be logged in to reply to this topic.